How to Upgrade the firmware version of TP-Link Wireless Router?

Notice:

1) Some models have multiple hardware versions. Please verify the hardware version of your device. When upgrading use only firmware for the same hardware version. Wrong firmware upgrading may damage your device and void the warranty.

To check the hardware version of your device please click here.

For example, if you have an Archer C7 version 4, you would choose version 4. Please find out the correct hardware version and read the important note before the upgrade.

2) Do NOT upgrade the firmware via wireless connection

3) Do NOT turn off the power or cut down the Ethernet cable during upgrade process

4)Please pay attention to the Notes of the firmware you downloaded. In some cases new firmware cannot support a backup file of the older firmware. If this is the case, you will need to reconfigure the router manually.

 

Step 1

Download the latest firmware version for your device.

Go to download center for your Region on the TP-Link website. Then, select the appropriate drop downs for your TP-Link product.  Choose the corresponding hardware version, click on Firmware.  A list of available firmware will be displayed.

 

The 6 digits in the firmware means the published date.

Step 2

Unzip/extract the Firmware from the downloaded .ZIP file

Step 3

Login to the TP-Link router’s web management page.

How do I log into the web-based Utility (Management Page) of TP-Link wireless router?

Step 4

Click on System Tools-Firmware Upgrade (or Firmware); click on Browse/Choose File to find the extracted firmware file and click open.

 

Step 5 

Click the Upgrade button. The device will reboot automatically after the upgrade has been finished. 

Step 6 

Click Status, check if the router’s firmware has been upgraded

Step 7

Some firmware updates will restore your router to factory settings.  If this is the case run the Quick Setup Wizard to reconfigure your TP-Link router.

Ten artykuł dotyczy:
TL-WR841N , TL-WDR3500 , TL-WR743ND
User Application Requirement | Updated 05-25-2017 07:06:03 AM